Announcement

Collapse
No announcement yet.

Hangs with AppleTV setup (FW35)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Hangs with AppleTV setup (FW35)

    My setup is a AppleTV (2021) connected to Nakamichi 9.2.4 (2019), which is then connected to my LG TV. I had encountered several issues earlier this year and posted on this forum, at which I was offered a firmware update of a more recent version of FW35.

    after this update I am seeing a new set of issues. Since the time I bought this soundbar, I had configured HDMI-CEC and had no issues with turning on/off all 3 devices with my Apple TV remote. However after this update that seems to be broken. When I power on my Apple TV with its remote (like I always used to do), neither the TV not the soundbar turn on, and worse, the Apple TV just hangs and is unresponsive to any buttons. The only solution is to restart the Apple TV. This happens every day.

    any help on this would be appreciated. Thanks in advance.

  • #2
    Hey, I and some other users have the same problem as you, I actually made a post about it here:

    https://community.nakamichi-usa.com/...ion-cec-broken

    In that post is also a link to another forum where others have the same problems too

    Comment


    • #3
      We're working on researching this as we too are experiencing some trouble with the last Apple TV software update. The behavior of the Apple TV is as follows:
      1. Powering on the Apple TV with the Siri remote after immediately plugging in results in a 2 second delay from when the device is powered on, to when the soundbar/ TV receive the CEC command to wake up.
      2. Allowing the Apple TV to go into deep sleep mode (after around 2 minutes) results in around a minute delay for the CEC signal to reach TV/ soundbar.
      3. Allowing the Apple TV more time to wait while in standby can result in one of the following:
      a) The TV/soundbar takes a particularly long time to wake up the soundbar (over 3 minutes.)
      b) The TV/soundbar do not wake up with the Apple TV no matter how many commands you send, and the Apple TV does not power down when you press/ hold down the power button.

      In the last situation we found that the Apple TV would "freeze." In actuality when you manually select inputs for the Apple TV the remote may be bugged. You cannot control any of the face buttons other than the direction/ touch pad. This prevents the device from sending or receiving CEC commands. When unplugged from the soundbar and plugged directly into the TV, this still occurred. Even when unplugged from HDMI entirely the Apple TV would not shut down with it's own remote.

      After some research on our side, along with tips from the MacRumors forum we found out this is likely related to bugs with the Siri remote's command programming. When testing the 2021 Apple TV 4K with the 1st generation remote we found these issues were non-existent.

      We ask anyone who owns the 1st generation remote to pair it with their Apple TV and see for themselves the performance difference. We have done some research with other brand receivers and found mixed results. In some cases (like with a Samsung N850) the Apple TV's would break handshakes with the TV when connected to other devices, so it's likely the Shockwafe soundbar is refusing commands to prevent CEC meltdowns like this. We're still investigating this performance, but since the disruption is only occurring with one device, and only with one remote, we're not certain why/ how the soundbar/ receiver effects this performance.

      If you do not have the 1st generation remote there are a few options:

      1. When the remote freezes you can still use the Direction/ touch pad. Manually select inputs with your TV's remote. Go to settings and restart your Apple TV, this usually refreshes the connection and allows for proper control.

      2. Allow your Apple TV around 5 - 10 Minutes to regain control. After this amount of time the device should allow commands again/ "un-freeze." Once this time passes the Apple TV 4K begins acting as intended.

      Since the Apple TV stays in this state when unplugged from HDMI (still will not power down with the power button) this is likely something that will need to be patched by Apple via software. I recall the first version of the remote firmware released before August of this year worked fine, so I do believe this is something Apple will need to patch.

      I'll have some videos showing the performance/ what to look out for when this occurs. If you have any questions about how you soundbar/ TV are controlled by source devices please feel free to reach out to our support team via: [email protected]

      Regards,
      Head Ninja

      Comment


      • #4
        Thanks Nakamichi Ninjas for looking into this! I do agree that's the new Siri remote firmware released by Apple in August that's at the root of the problem.

        This reddit thread also shows people having problems with just the remote itself lagging and it has to be restarted for it to work well again:
        https://www.reddit.com/r/appletv/com...control_laggy/

        I can confirm that using the 1st gen remote, CEC works as intended.

        As I wrote in my other thread, my workaround for now until this gets fixed is to have the ATV learn the Nakamichi remote via IR for volume control:
        Settings--Remotes and Devices--Volume Control--Learn New Device

        By doing this, CEC works again, I can turn on the Nakamichi, TV, and ATV with the Siri remote. Of course the only downside is that since it's IR, I need to point the Siri remote towards the general area where the soundbar is but it's a pretty generous radius, I can kinda have it pointed to the side, towards the ceiling and etc, and it will still control the volume.

        The only thing that I'm wondering is why certain soundbars actually work after the Siri remote firmware upgrade. One of the guys in the MacRumors forum switched out the Nakamichi with the Vizio Elevate and he says that everything is working fine:
        https://forums.macrumors.com/threads.../post-30377667

        Hopefully a fix becomes available cause I do not want to get another soundbar as I like how the Nakamichi sounds compared to the rest of the competition.

        In case anyone is wondering what my setup and software version is:

        LG C8 - Firmware 5.40.09
        ATV 4K (2021) - Firmware tvOS 15.1 (RC)
        Siri Remote - Firmware 0x0061
        Nakamichi 9.2.4 - Firmware 35 (April beta)

        Click image for larger version  Name:	IMG_0257.JPG Views:	0 Size:	769.3 KB ID:	687
        Click image for larger version  Name:	IMG_0258.JPG Views:	0 Size:	569.5 KB ID:	685
        Last edited by Sparhawk; 10-20-2021, 09:56 AM.

        Comment


        • #5
          Sparhawk. Thanks for the tip, I was able to get mine working again when switching to IR for volume control. This issue was driving me crazy, I tried multiple different ATV hooked up to this TV and they all had the same issue, they work fine on my other TVs.

          Comment


          • Sparhawk
            Sparhawk commented
            Editing a comment
            Glad to have helped! Hopefully a fix comes soon

        • #6
          I informed Apple Support about Nakamichi’s response and acknowledgement there’s an issue. Their support acted completely clueless like they were unaware of any problems. I have been using the 1st gen 4K remote as a workaround to the CEC issues. One thing Apple had me do was re-pair the new 2nd gen Siri remote, and then go through the “learn new device” setup. I had to make the box learn the Siri up/down volume and mute controls. After that the CEC seemed to be working much better with the new remote. Still not as quick as with the 1st gen 4K remote, but still wake up the Nakamichi and my Sony tv within about 5 seconds.

          Comment

          Working...
          X